NoFwl

NoFwl 最新版

官方版 无广告 1,594

更新日期:2023-06-16 分类标签: 语言:中文 平台:

2 人已下载 手机查看

一个跨平台桌面应用程序

安装

ChatGPT_0.11.0_windows_x86_64.msi:下载安装程序

使用winget

# install the latest version
winget install --id=lencx.ChatGPT -e

# install the specified version
winget install --id=lencx.ChatGPT -e --version 0.11.0

如果安装路径和应用程序名称相同,会导致冲突

ChatGPT_0.11.0_macos_aarch64.dmg:下载安装程序

ChatGPT_0.11.0_macos_x86_64.dmg:下载安装程序

或者你可以使用Homebrew(cask)安装:

brew tap lencx/chatgpt https://github.com/lencx/ChatGPT.git
brew install --cask chatgpt --no-quarantine

另外,如果您保留Brewfile,您可以添加如下内容:

repo = "lencx/chatgpt"
tap repo, "https://github.com/#{repo}.git"
cask "chatgpt", args: { "no-quarantine": true }

提示:Homebrew安装没有使用最新版本,欢迎您提交PR来修复它。

ChatGPT_0.11.0_linux_x86_64:下载.deb安装程序,优点体积小,缺点兼容性差

ChatGPT_0.11.0_linux_x86_64.AppImage.tar.gz.deb :运行可靠,如果运行失败可以尝试一下

在AUR (非官方)上可用,包名称为chatgpt-desktop-bin,您可以使用您最喜欢的 AUR 包管理器来安装它。此包使用.deb发布页面中的安装程序,在构建过程中依赖较少。

也可在AUR(非官方)上使用,包名称为chatgpt-desktop-git,您可以使用您最喜欢的 AUR 包管理器来安装它。此包始终从分支的最新提交构建main,在构建过程中具有更多依赖项。

NoFwlNoFwlNoFwlNoFwlNoFwlNoFwl

 

提示

您可以查看Awesome-chatgpt-prompts来查找要导入到应用程序中的有趣功能。您还可以Sync Prompts一键同步所有内容,如果您不希望某些提示出现在斜杠命令中,您可以禁用它们。

NoFwlNoFwl
  • 在chatgpt文本输入区域中,输入以开头的字符/,调出命令提示符,按空格键,则默认会用与该命令关联的文本填充输入区域(注意:如果包含多个命令提示符,则只会选择第一个作为填充,您可以继续输入,直到第一个提示的命令是您想要的命令,然后按空格键。
  • 或者使用鼠标单击多个命令之一)。填充完成后,只需按 Enter 键即可。
  • 斜杠命令下,使用tab键修改标签内容{q}(仅支持单次修改#54)。使用键盘(向上箭头)和(向下箭头)键选择斜线命令。

 

NoFwlNoFwl

 

常问问题

使用安全吗

它是安全的,只是OpenAI ChatGPT 网站的包装,不存在其他数据传输(您可以检查源代码)。

可以设置代理吗?

我们还没有找到在这个程序中设置代理的方法(tauri只是不支持这个功能)),但是系统代理会自动使用。

提示:ChatGPT基于tauri,目前仍处于积极开发阶段,存在一些缺陷。

哪些错误不是由该程序引起的,而是由 OpenAI 引起的?

  • 验证你是人类
  • OpenAI 的服务在您所在的国家/地区不可用。
  • 您无权访问 chat.openai.com。错误代码:1020
  • ChatGPT 目前已满
  • 检查站点连接是否安全
  • 无法登录

提示:现阶段,ChatGPT只是OpenAI ChatGPT网站的包装,并带有一些有用的扩展。所以如果你的浏览器不能使用ChatGPT ,就意味着你也不能在这个程序中使用它。上面我们已经详细回答了哪些问题是由OpenAI引起的,与这个程序无关。

我无法使用关闭按钮关闭程序,为什么?

该应用定位为高频使用的工具,之所以不能通过窗口按钮关闭,是为了防止用户误触。请使用快捷方式Ctrl + Q或Quit菜单中的来关闭应用程序。

为什么这个程序不满足一些平台特定的要求(例如配置文件位置)?

有一个权衡:专注于开发一些特定于平台的功能和改进(有很多兼容性问题和特定于平台的代码)或者优先开发跨平台的功能和改进。在现阶段(早期阶段)项目),我们可能总是更喜欢后者。

为什么这个程序不支持xxx架构(例如Mac arm arch)/xxx封装(例如flatpack)?

  • 我们使用Github Actions来构建这个程序,现在脚本很难修改。
  • 我们对Linux的封装了解不多,也没有相应的环境来测试它们。

多个窗口

如果您已经在主窗口中登录,但系统托盘窗口显示您尚未登录,您可以通过重新启动应用程序来修复它(菜单 -> 首选项 -> 重新启动 ChatGPT)

平台特定问题

无法验证开发者?

打开来自身份不明的开发者的 Mac 应用

支持的最低系统

我们的用户报告最低支持的系统版本是 10.14.6+,但我们尚未对其进行测试。

MacOS macos_aarch64 似乎坏了

打开终端并尝试以下命令:

xattr -r -d com.apple.quarantine /YOUR_PATH/ChatGPT.app

https://github.com/lencx/ChatGPT/issues/461

https://github.com/lencx/ChatGPT/issues/595

错误代码:

https://github.com/tauri-apps/tauri/issues/4659#issuecomment-1452897588

 

配置

应用

平台小路
Linux/home/lencx/.chatgpt
苹果系统/Users/lencx/.chatgpt
视窗C:Userslencx.chatgpt

[.chatgpt]- 应用程序配置根文件夹

  • chat.conf.json- 首选项配置
  • chat.awesome.json- 自定义 URL 列表,类似于浏览器书签。任何 URL 都可以用作主窗口或托盘窗口(控制中心 -> Awesome
  • chat.model.json- 提示配置,包含三部分:

    1.user_custom- 需要手动数据输入(控制中心 -> 语言模型 -> 用户自定义
    2.sync_prompts-从f/awesome-chatgpt-prompts同步数据(控制中心 -> 语言模型 -> 同步提示
    3.sync_custom- 同步自定义json和csv文件数据,支持本地和远程(控制中心 -> 语言模型 -> 同步自定义

  • chat.model.cmd.json- 过滤(是否启用)和排序的斜杠命令
  • [cache_model]- 缓存模型数据
    1.chatgpt_prompts.json- 缓存sync_prompts数据
    2.user_custom.json- 缓存user_custom数据
    3.ae6cf32a6f8541b499d6bfe549dbfca3.json- 随机生成文件名、缓存sync_custom数据
    4.4f695d3cfbf8491e9b1f3fab6d85715c.json- 随机生成文件名、缓存sync_custom数据
    5.bd1b96f15a1644f7bd647cc53073ff8f.json-随机生成文件名、缓存sync_custom数据

同步自定义

目前同步自定义文件仅支持JSON和CSV,且需要满足以下格式,否则应用会异常:

JSON format:

[
{
"cmd": "a",
"act": "aa",
"prompt": "aaa aaa aaa"
},
{
"cmd": "b",
"act": "bb",
"prompt": "bbb bbb bbb"
}
]

CSV format:

"cmd","act","prompt"
"a","aa","aaa aaa aaa"
"b","bb","bbb bbb bbb"

 

菜单

偏好

  • Control Center:ChatGPT应用程序的控制中心,它将赋予应用程序无限的想象空间。
  • Stay On Top:该窗口位于其他窗口之上。
  • Titlebar:是否显示标题栏,仅macOS支持。
  • Hide Dock Icon#35 ):从 Dock 隐藏应用程序图标(仅支持 macOS)。
    右键单击系统托盘打开菜单,然后单击Show Dock Icon菜单项以在 Dock 中重新显示应用程序图标 ( SystemTrayMenu -> Show Dock Icon)。
  • Inject Script:使用脚本修改页面。
  • ThemeLightDarkSystem(仅支持 macOS 和 Windows)。
  • Go to Config:打开配置文件目录(path: ~/.chatgpt/*)。
  • Clear Config:清除配置文件(path: ~/.chatgpt/*),危险操作,请提前备份数据。
  • Restart ChatGPT:重新启动应用程序,例如:程序卡住或者注入脚本编辑后重新启动应用程序即可生效。

窗户

  • ChatGPT User's Guide
  • DALL·E 2

帮助

  • ChatGPT Log
  • Update Log
  • Report Bug
  • Report Bug
  • Toggle Developer Tools

 

建造

预安装

开始

# step1:
git clone https://github.com/lencx/ChatGPT.git

# step2:
cd ChatGPT

# step3: install deps
yarn

# step4:
yarn dev

# step5:
# bundle path: src-tauri/target/release/bundle
yarn build

distDir 配置设置为“../dist”,但该路径不存在。

错误 已找到公钥,但未找到私钥。确保设置 TAURI_PRIVATE_KEY 环境变量。

相关软件

暂无评论

暂无评论...